In progress
Maintenance has started
Scheduled
Updated time for the scheduled maintenance
Scheduled
Between 01:55 and 07:05 UK time, on 13 September 2026, inbound and outbound payments will be delayed. This is due to scheduled maintenance work being carried out by our payment provider. During that time: Any inbound payments sent to us will be queued and processed once the maintenance period has ended. We will queue any outbound payments that you submit and process them once the maintenance period has ended.